aboutsummaryrefslogtreecommitdiffstats
path: root/community/kig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kig/APKBUILD')
-rw-r--r--community/kig/APKBUILD43
1 files changed, 22 insertions, 21 deletions
diff --git a/community/kig/APKBUILD b/community/kig/APKBUILD
index 530b5ccabb0..b07ef8afe0c 100644
--- a/community/kig/APKBUILD
+++ b/community/kig/APKBUILD
@@ -1,33 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kig
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
-url="https://edu.kde.org/kig"
pkgdesc="Interactive Geometry"
+url="https://edu.kde.org/kig"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- karchive-dev
- kconfigwidgets-dev
- kcoreaddons-dev
- kcrash-dev
- kdoctools-dev
- ki18n-dev
- kiconthemes-dev
- kparts-dev
- ktexteditor-dev
- kxmlgui-dev
+ karchive5-dev
+ kconfigwidgets5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kiconthemes5-dev
+ kparts5-dev
+ ktexteditor5-dev
+ kxmlgui5-dev
qt5-qtbase-dev
qt5-qtsvg-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kig-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kig.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kig-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -38,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +48,5 @@ package() {
}
sha512sums="
-d2489e27443561d9921a1adb7cb1f7a781bba1c444216fa02586623ad9ed6128d5f3261d2b8e0dd7c3ceda3d8a58b626c8891f860db96f6a734177bbe0d1399c kig-22.04.2.tar.xz
+458d33b14f0f679a9f51ac47a5c2343772cf3b9c5325eb3b0832e1172b05d21bcab8b6ce3dab8342390196d7b912681306b4868e0e223b8c2da413cecdad5b99 kig-24.02.1.tar.xz
"