aboutsummaryrefslogtreecommitdiffstats
path: root/community/killbots/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/killbots/APKBUILD')
-rw-r--r--community/killbots/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/killbots/APKBUILD b/community/killbots/APKBUILD
index aa144a494e7..bb4f351bf46 100644
--- a/community/killbots/APKBUILD
+++ b/community/killbots/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=killbots
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="A simple game of evading killer robots"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/killbots/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -22,15 +24,18 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/killbots-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/killbots.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/killbots-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -41,5 +46,5 @@ package() {
}
sha512sums="
-8614229a38bc4c84a5cbcbc51df7fdc4d93065a7bd2c82052a4f0fd57230a0447a0150b4a99d02144fc26c58f59dc75e2065d18676f69f9a83a3077a7e2cc41c killbots-21.08.2.tar.xz
+a17378932810f9bea90d3821c1d393c842f697b456bda533135c628728111391ee34bbfd1a40d5b285e366e6bfc003600f80d0f8de616416be4447c7c40c6150 killbots-24.02.2.tar.xz
"