aboutsummaryrefslogtreecommitdiffstats
path: root/community/kimap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kimap/APKBUILD')
-rw-r--r--community/kimap/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/kimap/APKBUILD b/community/kimap/APKBUILD
index 19392cf7cc3..075a12f7968 100644
--- a/community/kimap/APKBUILD
+++ b/community/kimap/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kimap
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="Job-based API for interacting with IMAP servers"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by kio-dev
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends_dev="
@@ -15,14 +17,15 @@ depends_dev="
ki18n-dev
kio-dev
kmime-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kimap-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/pim/kimap.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kimap-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -33,10 +36,8 @@ build() {
}
check() {
- cd build
-
# loginjobtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "loginjobtest"
+ ctest --test-dir build --output-on-failure -E "loginjobtest" -j1
}
package() {
@@ -44,5 +45,5 @@ package() {
}
sha512sums="
-1491ee7f5483b6d24be38d311065c7d24ebf6752dfb7f7eed130352f030523276309778173a4537cae5cc0bfbf13ef0e89c84683560d974c9838d71c7502bc04 kimap-22.04.2.tar.xz
+261f38d3bb048fbe58f2da22b3501b495e9571bd32d249b93982171c1389309caac7c11aad2ee5198e3deee7c7db95a6ebf33c0a2e7d581d26d583daf6703e8a kimap-24.02.2.tar.xz
"