aboutsummaryrefslogtreecommitdiffstats
path: root/community/kinfocenter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kinfocenter/APKBUILD')
-rw-r--r--community/kinfocenter/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index 9549d729f57..cce00a29521 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kinfocenter
-pkgver=5.22.4
+pkgver=6.0.3
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
@@ -30,7 +32,9 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ libusb-dev
+ qt6-qtbase-dev
+ samurai
solid-dev
solid-dev
"
@@ -39,20 +43,20 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kinfocenter-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/kinfocenter.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kinfocenter-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -60,5 +64,5 @@ package() {
}
sha512sums="
-cb48dbe47e8d65441ba59fa1617a685218482a13099dc83667a37cfa512e0db2f0dbb954e26055926dede8ec52eebfe60312471b735b3abd1f229c3286979b14 kinfocenter-5.22.4.tar.xz
+e34736aeae47de1814bfcbf073cd8814016c9d1dda1de440be14918e9dd44e0d8d00ec8a589a1ddb7d10e31421a27159b4bf05634bba2597f11e6f7d76ac3ef3 kinfocenter-6.0.3.tar.xz
"