aboutsummaryrefslogtreecommitdiffstats
path: root/community/kinfocenter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kinfocenter/APKBUILD')
-rw-r--r--community/kinfocenter/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index b2a6fa0673b..fc9f83b8253 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=kinfocenter
-pkgver=5.25.2
+pkgver=6.0.4
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
@@ -30,7 +32,8 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ libusb-dev
+ qt6-qtbase-dev
samurai
solid-dev
solid-dev
@@ -40,8 +43,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/kinfocenter-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/kinfocenter.git"
+source="https://download.kde.org/stable/plasma/$pkgver/kinfocenter-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -52,8 +56,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -61,5 +64,5 @@ package() {
}
sha512sums="
-163cc8f501f6c91109bbd5f3b324a5224b47fa81c0b4664da671849799b76ad0dced78d9f9a18d1248bad381f95b8095a90eeafc6ca487d46905621ef5c363f2 kinfocenter-5.25.2.tar.xz
+1c3214d844576a4bcfff49e05d316031688fb76355e302097e68140ffbf20feb33d47b0c3a1db067dc63bf0944e5d49b8f3cafd9cbf6e43aaf8fc9ace81b38a4 kinfocenter-6.0.4.tar.xz
"