aboutsummaryrefslogtreecommitdiffstats
path: root/community/kio-fuse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kio-fuse/APKBUILD')
-rw-r--r--community/kio-fuse/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/kio-fuse/APKBUILD b/community/kio-fuse/APKBUILD
index c0336806e5b..8e2541214ab 100644
--- a/community/kio-fuse/APKBUILD
+++ b/community/kio-fuse/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=kio-fuse
-pkgver=5.0.1
-pkgrel=2
+pkgver=5.1.0
+pkgrel=1
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/"
pkgdesc="FUSE interface for KIO"
license="GPL-3.0-only"
@@ -15,11 +17,12 @@ makedepends="
kcoreaddons-dev
kdbusaddons-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
checkdepends="dbus"
-source="https://download.kde.org/stable/kio-fuse/$pkgver/kio-fuse-$pkgver.tar.xz
+_repo_url="https://invent.kde.org/system/kio-fuse.git"
+source="https://download.kde.org/stable/kio-fuse/kio-fuse-$pkgver.tar.xz
modules-load.conf
kio-fuse.desktop
"
@@ -28,6 +31,7 @@ options="!check" # Only test is broken
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -35,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -50,6 +53,8 @@ package() {
rm -r "$pkgdir"/usr/lib/systemd
}
-sha512sums="6423c461c001bb27d4e17e6f9a69e4a28c2e7834b6702bd14e4b34db9fc3156cdbb5400ec2c3f15975e78e563abbf14412f8f1b1db05f6313a8520bab030e7bd kio-fuse-5.0.1.tar.xz
+sha512sums="
+273b75fe90f8cb31ee0f611716bf05384d78d21747cb43785bb7a91037ca9ac30233aee5081e467d46aa21aa03f4c0fc7583334fe34dec7530c89c818db41a4b kio-fuse-5.1.0.tar.xz
57d23d2778556eafc3035e6be575bf95b4032f123b35f2b1657eff5e7496de253173edc657f90531ee58e25673f4f27a5cd1cc76b14a038edb244f104a231771 modules-load.conf
-94a5acc6d6b622f923e6fa077cac63f365ad1a0828690336421368f7300179b39318b10c5e6490de7c442e2713dc25b2b3fb17fee4ac4064595a474ea50c2137 kio-fuse.desktop"
+94a5acc6d6b622f923e6fa077cac63f365ad1a0828690336421368f7300179b39318b10c5e6490de7c442e2713dc25b2b3fb17fee4ac4064595a474ea50c2137 kio-fuse.desktop
+"