aboutsummaryrefslogtreecommitdiffstats
path: root/community/kio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kio/APKBUILD')
-rw-r--r--community/kio/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index d8983b87365..50fa1298fb1 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -1,14 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kio
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Resource and network access abstraction"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends="kded"
depends_dev="
+ acl-dev
karchive-dev
kbookmarks-dev
kcompletion-dev
@@ -26,7 +31,6 @@ depends_dev="
kwallet-dev
kwidgetsaddons-dev
kwindowsystem-dev
- qt5-qtscript-dev
solid-dev
"
makedepends="$depends_dev
@@ -35,13 +39,15 @@ makedepends="$depends_dev
kdoctools-dev
libxml2-dev
libxslt-dev
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
+subpackages="$pkgname-dev $pkgname-dbg $pkgname-doc $pkgname-lang $pkgname-kwallet"
+_repo_url="https://invent.kde.org/frameworks/kio.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-kwallet"
-options="!check" # Fails due to requiring physical devices not normally available and test 14 hangs
+# Checks fails due to requiring physical devices not normally available and test 14 hangs
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -53,8 +59,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -64,9 +69,9 @@ package() {
kwallet() {
pkgdesc="$pkgname KWallet integration"
- amove usr/lib/qt5/plugins/kf5/kiod/kpasswdserver.so
+ amove usr/lib/qt6/plugins/kf6/kiod/kpasswdserver.so
}
sha512sums="
-bb6e8e45cf9f5e0a076c6bdfee765103409eff22cad41419a49abf59ed1c1fe73db7f186ec8ea2d6dd6fa26787596732870e8db63d69ed6a241ac721cde08ab7 kio-5.97.0.tar.xz
+dcdd0a13d7e44c75ddd19d6d03e6c57b90c2b47f1141b6dc23054dc029a11358bb9748b8bb2115129cc1ab3769034728b3dd35507772807542376b3ef7b47707 kio-6.1.0.tar.xz
"