aboutsummaryrefslogtreecommitdiffstats
path: root/community/kio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kio/APKBUILD')
-rw-r--r--community/kio/APKBUILD47
1 files changed, 28 insertions, 19 deletions
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index 395357f97f8..50fa1298fb1 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -1,15 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kio
-pkgver=5.84.0
-pkgrel=1
+pkgver=6.1.0
+pkgrel=0
pkgdesc="Resource and network access abstraction"
- # armhf blocked by extra-cmake-modules
- # mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends="kded"
depends_dev="
+ acl-dev
karchive-dev
kbookmarks-dev
kcompletion-dev
@@ -27,7 +31,6 @@ depends_dev="
kwallet-dev
kwidgetsaddons-dev
kwindowsystem-dev
- qt5-qtscript-dev
solid-dev
"
makedepends="$depends_dev
@@ -36,18 +39,19 @@ makedepends="$depends_dev
kdoctools-dev
libxml2-dev
libxslt-dev
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz
- 0001-Fix-selecting-binaries-from-component-chooser-KCM.patch
- "
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring physical devices not normally available and test 14 hangs
+subpackages="$pkgname-dev $pkgname-dbg $pkgname-doc $pkgname-lang $pkgname-kwallet"
+_repo_url="https://invent.kde.org/frameworks/kio.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz"
+# Checks fails due to requiring physical devices not normally available and test 14 hangs
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -55,14 +59,19 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
+kwallet() {
+ pkgdesc="$pkgname KWallet integration"
+
+ amove usr/lib/qt6/plugins/kf6/kiod/kpasswdserver.so
+}
+
sha512sums="
-4c041b33171014562469c8ee074f85595edd503c0cb4c66aa5a17bad24937b71094826df2f3734b3d244d93b812e933f6ddc095628f2b25d5fca34c793383af9 kio-5.84.0.tar.xz
-3dcc1fd0c70aacd6c4417654e741e28540c6f583ed7bd21ce27c2728bf6a4a9f910d92cb6445c6c10d2f6eceff40d4a0d7b8c3ac7ac678e4299745998a0f9fd8 0001-Fix-selecting-binaries-from-component-chooser-KCM.patch
+dcdd0a13d7e44c75ddd19d6d03e6c57b90c2b47f1141b6dc23054dc029a11358bb9748b8bb2115129cc1ab3769034728b3dd35507772807542376b3ef7b47707 kio-6.1.0.tar.xz
"