aboutsummaryrefslogtreecommitdiffstats
path: root/community/kio
diff options
context:
space:
mode:
Diffstat (limited to 'community/kio')
-rw-r--r--community/kio/0001-fix-crash-retry.patch32
-rw-r--r--community/kio/APKBUILD9
2 files changed, 3 insertions, 38 deletions
diff --git a/community/kio/0001-fix-crash-retry.patch b/community/kio/0001-fix-crash-retry.patch
deleted file mode 100644
index a4b87821e20..00000000000
--- a/community/kio/0001-fix-crash-retry.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From a183dd0d1ee0659e5341c7cb4117df27edd6f125 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Tue, 2 Feb 2021 11:31:40 +0200
-Subject: [PATCH] CopyJob: fix crash with skip/retry
-
-The crash was happening because I was disconnecting the wrong signal in
-the lambda connected to KIO::AskUserActionInterface::askUserSkipResult...
-
-BUG: 431731
-FIXED-IN: 5.79
----
- src/core/copyjob.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/copyjob.cpp b/src/core/copyjob.cpp
-index cee40a62..cb16010f 100644
---- a/src/core/copyjob.cpp
-+++ b/src/core/copyjob.cpp
-@@ -1578,8 +1578,8 @@ void CopyJobPrivate::slotResultErrorCopyingFiles(KJob *job)
- QObject::connect(askUserActionInterface, &KIO::AskUserActionInterface::askUserSkipResult,
- q, [=](SkipDialog_Result result, KJob *parentJob) {
- Q_ASSERT(parentJob == q);
-- // Only receive askUserRenameResult once per rename dialog
-- QObject::disconnect(askUserActionInterface, &KIO::AskUserActionInterface::askUserRenameResult,
-+ // Only receive askUserSkipResult once per skip dialog
-+ QObject::disconnect(askUserActionInterface, &KIO::AskUserActionInterface::askUserSkipResult,
- q, nullptr);
- processFileRenameDialogResult(it, result, QUrl() /* no new url in skip */, QDateTime{});
- });
---
-GitLab
-
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index 4b9adc05cdc..fd5f299d885 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kio
-pkgver=5.78.0
+pkgver=5.79.0
pkgrel=0
pkgdesc="Resource and network access abstraction"
arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
@@ -37,9 +37,7 @@ makedepends="$depends_dev
qt5-qttools-dev
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz
- 0001-fix-crash-retry.patch
- "
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kio-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Fails due to requiring physical devices not normally available and test 14 hangs
@@ -60,5 +58,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="55996a35f77442f3cc2ff98708da6dfd2734b0afffd7b3b90b5b2845c9770f3ec68a1e4e72d21b1c4e41d06778ab376b96ab64d958c89dd4f8b7fad6501a5db7 kio-5.78.0.tar.xz
-25025c377c1406636505781b7e793a6ca8447512d1f4a7d73b2b7527e07c1893c45613310371f1aad8f85e1c9cab38152afd1118b3df9ac468b88801b5968b75 0001-fix-crash-retry.patch"
+sha512sums="7d7588ec61b3c85ec1d89e95ebee5c6d98626dafc4d80525e13baa96840e91a00a7fa6e6fd2e8055c78b22c27d37cdc395da6c23e521a4ae7ccbe4992f1f7c43 kio-5.79.0.tar.xz"