aboutsummaryrefslogtreecommitdiffstats
path: root/community/kitemmodels/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kitemmodels/APKBUILD')
-rw-r--r--community/kitemmodels/APKBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/community/kitemmodels/APKBUILD b/community/kitemmodels/APKBUILD
index e5df92ff639..75373fe963e 100644
--- a/community/kitemmodels/APKBUILD
+++ b/community/kitemmodels/APKBUILD
@@ -1,27 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kitemmodels
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Models for Qt Model/View system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only AND LGPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev"
+depends_dev="qt6-qtbase-dev"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qtdeclarative-dev
- qt5-qttools-dev
+ qt6-qtdeclarative-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kitemmodels-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kitemmodels.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kitemmodels-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -29,9 +34,9 @@ build() {
}
check() {
- cd build
# kdescendantsproxymodel_smoketest and kdescendantsproxymodeltest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kdescendantsproxymodel(_smoketest|test)"
+ # # kselectionproxymodeltest
+ xvfb-run ctest --test-dir build --output-on-failure -E "(kselectionproxymodel|kdescendantsproxymodel(_smoke|))test"
}
package() {
@@ -39,5 +44,5 @@ package() {
}
sha512sums="
-ce4a7ac7797caa4d63bfe3ef5dccdd6a196bf1dbf0bb724a672928cb3791a6693780ba15817780c7e4a4d46ff511601aa92a7247b09de45b870b7dce5a1fe04c kitemmodels-5.90.0.tar.xz
+d256ed99a6d1e7780650f4720da0b25f46b0caa7c42600e9eb62e91b4ba03a5baaaf28cfe9aa0f76e33bc248567065ebd874d16b41f7a0930c6e0985b932225c kitemmodels-6.1.0.tar.xz
"