aboutsummaryrefslogtreecommitdiffstats
path: root/community/kiten/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kiten/APKBUILD')
-rw-r--r--community/kiten/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/kiten/APKBUILD b/community/kiten/APKBUILD
index a6cc64615a3..717114bbee7 100644
--- a/community/kiten/APKBUILD
+++ b/community/kiten/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kiten
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/kiten/"
pkgdesc="Japanese Reference/Study Tool"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,27 +20,27 @@ makedepends="
kcoreaddons-dev
kcrash-dev
kdoctools-dev
- khtml-dev
ki18n-dev
+ kio-dev
knotifications-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kiten-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kiten.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kiten-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +48,5 @@ package() {
}
sha512sums="
-22ae9b0ead5f6a8c30cff5fd5d29c7273c5e0844d0494b136d82245dc60d0d4635f9a83b61b94136554f545a7c3ddd51342c4072def2ba8050ef7a73f60da695 kiten-21.04.3.tar.xz
+e20641bb761d3a20ae7f95f05cb3949a0c56e96ef24a854c710721b7dc003cb36776222bf71fa99aaeaed3c31a799db9eb841b5fa09739e8edf4d1f2b0dab96a kiten-24.02.1.tar.xz
"