aboutsummaryrefslogtreecommitdiffstats
path: root/community/kjumpingcube/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kjumpingcube/APKBUILD')
-rw-r--r--community/kjumpingcube/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/kjumpingcube/APKBUILD b/community/kjumpingcube/APKBUILD
index 3041be61bba..3983f267717 100644
--- a/community/kjumpingcube/APKBUILD
+++ b/community/kjumpingcube/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kjumpingcube
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
-pkgdesc="A simple tactical game"
+pkgdesc="A simple dice driven tactical game"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
-url="https://kde.org/applications/games/kjumpingcube/"
+arch="all !armhf"
+url="https://apps.kde.org/kjumpingcube/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -22,16 +24,19 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kjumpingcube-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kjumpingcube.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kjumpingcube-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,5 +47,5 @@ package() {
}
sha512sums="
-5f82f9debad4b0136166a8427b3c58ca39658f194edbdcccadb47c848082e5c7364fc5f80a93628ec30f4cdaa2c127dc3ce5023bbb3aab9f3314972d7cb68588 kjumpingcube-21.04.3.tar.xz
+b9c4dce78188d62a45d17067b2a2a4b44ddada7713cd531ef8ff99bc09513e50b71c8f6e0fcd556c6cc3657ed3a00852b39a66fd44c2a7d1fd27fc8332ab80e2 kjumpingcube-24.02.2.tar.xz
"