aboutsummaryrefslogtreecommitdiffstats
path: root/community/kjumpingcube/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kjumpingcube/APKBUILD')
-rw-r--r--community/kjumpingcube/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/kjumpingcube/APKBUILD b/community/kjumpingcube/APKBUILD
index 546335a7cc7..c4a552aa79f 100644
--- a/community/kjumpingcube/APKBUILD
+++ b/community/kjumpingcube/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kjumpingcube
-pkgver=21.08.3
+pkgver=24.02.1
pkgrel=0
-pkgdesc="A simple tactical game"
+pkgdesc="A simple dice driven tactical game"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
-url="https://kde.org/applications/games/kjumpingcube/"
+arch="all !armhf"
+url="https://apps.kde.org/kjumpingcube/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -22,16 +24,19 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kjumpingcube-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kjumpingcube.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kjumpingcube-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,5 +47,5 @@ package() {
}
sha512sums="
-a5bbf57574c1a787c1a841e5f43105ac9f412a0e3f30545007bd3b424ae7f854309b7f77d5edffc853cc44741252ded342b0cdfec12d9dcc697c33a1b4f03270 kjumpingcube-21.08.3.tar.xz
+b91d435d3efc74ebddf390bbb543178eb2318fa7543040796fa02a2a7158dda4b5c6d618ff325b46e1931852e59e919050a7dcb3a8e332b28e2f994c3d76bd45 kjumpingcube-24.02.1.tar.xz
"