aboutsummaryrefslogtreecommitdiffstats
path: root/community/kldap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kldap/APKBUILD')
-rw-r--r--community/kldap/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/kldap/APKBUILD b/community/kldap/APKBUILD
index 96fba5304df..ad5c5a598b1 100644
--- a/community/kldap/APKBUILD
+++ b/community/kldap/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kldap
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
pkgdesc="LDAP access API for KDE"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
-url="https://github.com/kde/kldap"
+arch="all !armhf"
+url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="
kcompletion-dev
@@ -16,31 +18,33 @@ depends_dev="
kio-dev
kwidgetsaddons-dev
openldap-dev
- qt5-qtkeychain-dev
+ qtkeychain-dev
"
makedepends="$depends_dev
extra-cmake-modules
cyrus-sasl-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kldap-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kldap.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kldap-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-01e9a36e212d912f86c43c1a6af9b56f48c5ae041b17e282bd2b3d913257a757e6b43bda756507fe50068b3ded17506e3427df0bed2a9114d327fb808dca3e15 kldap-21.04.3.tar.xz
+7b33b635839ab90d3688efc986a11eeeed88cb899066bc074005514773f1339a9ed3314661bcf9b89b71591de3ca702f9990d3abf84ff30bf70fa55175fab9a9 kldap-24.02.1.tar.xz
"