aboutsummaryrefslogtreecommitdiffstats
path: root/community/kleopatra/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kleopatra/APKBUILD')
-rw-r--r--community/kleopatra/APKBUILD60
1 files changed, 46 insertions, 14 deletions
diff --git a/community/kleopatra/APKBUILD b/community/kleopatra/APKBUILD
index c56f427deec..223feb61ebd 100644
--- a/community/kleopatra/APKBUILD
+++ b/community/kleopatra/APKBUILD
@@ -1,38 +1,70 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kleopatra
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x"
url="https://www.kde.org/applications/utilities/kleopatra/"
pkgdesc="Certificate Manager and Unified Crypto GUI"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-depends="gnupg pinentry-qt"
-makedepends="extra-cmake-modules qt5-qtbase-dev kcmutils-dev kwidgetsaddons-dev kconfigwidgets-dev kcoreaddons-dev kcodecs-dev kconfig-dev ki18n-dev kiconthemes-dev kitemmodels-dev kxmlgui-dev kwindowsystem-dev kdoctools-dev kcrash-dev kdoctools-dev kdbusaddons-dev gpgme-dev qgpgme libkleo-dev kmime-dev libassuan-dev boost-dev"
+depends="
+ gnupg
+ pinentry-qt
+ "
+makedepends="
+ boost-dev
+ extra-cmake-modules
+ gpgme-dev
+ kcmutils-dev
+ kcodecs-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kdoctools-dev
+ ki18n-dev
+ kiconthemes-dev
+ kitemmodels-dev
+ kmbox-dev
+ kmime-dev
+ kstatusnotifieritem-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ libassuan-dev
+ libkleo-dev
+ mimetreeparser-dev
+ qgpgme
+ qt6-qtbase-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kleopatra-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kleopatra.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kleopatra-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
-
# kuniqueservicetest requires running dbus
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kuniqueservicetest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "kuniqueservicetest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-4cc6298b992d1c917226caba4f3e6592cabd33eaf9164e94fb58ecdc6c939417fcf88e018b0867e6d5baa8eddc5de6b64d9a7bb137ad641085ddf8b8511bb5d3 kleopatra-21.04.3.tar.xz
+fdc415dacddcc85338994c03b624219b4de44acbf5fc5838fb450605e1a55224325b0eeb90461bfdb5524485fe13f3154ead45a3821b12e286496c8bf73044dc kleopatra-24.02.1.tar.xz
"