aboutsummaryrefslogtreecommitdiffstats
path: root/community/klettres/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/klettres/APKBUILD')
-rw-r--r--community/klettres/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/klettres/APKBUILD b/community/klettres/APKBUILD
index a31e8d75aed..e67349f4561 100644
--- a/community/klettres/APKBUILD
+++ b/community/klettres/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=klettres
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/klettres"
pkgdesc="Learn the Alphabet"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -19,24 +21,24 @@ makedepends="
ki18n-dev
knewstuff-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/klettres-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/klettres.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/klettres-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +46,5 @@ package() {
}
sha512sums="
-aac66aa6e8b87d186b7f72c32bb924292b42396b594a18be4bbd7a5c57803b8ee5931f618f0085212b200e17e172124f1e804d84b408fee8c00bbaf843cd730e klettres-21.08.3.tar.xz
+1fb6a61d0fd9303f9a912aea8c8543ae7643778cd6c0467296179a574df57ff1c704f3e647eeb98e34fc115fa786310ee159555a4c7e07a4a2a9aed176381470 klettres-24.02.2.tar.xz
"