aboutsummaryrefslogtreecommitdiffstats
path: root/community/klickety/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/klickety/APKBUILD')
-rw-r--r--community/klickety/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/klickety/APKBUILD b/community/klickety/APKBUILD
index f3e0dc5a2ba..dd6b17efde9 100644
--- a/community/klickety/APKBUILD
+++ b/community/klickety/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=klickety
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="An adaptation of the Clickomania game"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/klickety/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -22,12 +24,14 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/klickety-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/klickety.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/klickety-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-158b96581dbf6e279eb870d0206b35640f34f556a9ec6f6923021fdfde31401da2b331fe45f363455ee84e5725ca3681725f5df793e614545716b9486727a12a klickety-22.04.3.tar.xz
+a0b28691ae32c191bfb162003d220e79be645e7aa4ed068dac8915e4c23f3739ec3146e758cf01054dad63af14c264c3fa6a18063149845593bf172b169d1d8b klickety-24.02.2.tar.xz
"