aboutsummaryrefslogtreecommitdiffstats
path: root/community/klines/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/klines/APKBUILD')
-rw-r--r--community/klines/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/klines/APKBUILD b/community/klines/APKBUILD
index 36df31facda..d34dfb84b41 100644
--- a/community/klines/APKBUILD
+++ b/community/klines/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=klines
-pkgver=21.08.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/klines/"
pkgdesc="A simple but highly addictive one player game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,15 +23,18 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/klines-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/klines.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/klines-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -40,5 +45,5 @@ package() {
}
sha512sums="
-b79531abe661726715176cd22276801a54b4b6ed54a42505533173c68ecfea9e9c3306d0d1bbf4fab0b5629f3e24f7e0a849a2e18e8cf110fee0a0a43162e27f klines-21.08.1.tar.xz
+2b70c72964e190a59e26f8da922f58a137003c1be58d52009c67f071dc59f78f77d29b221cc0ad9675f12beb059c8b5e7578ad66d0f67b597f733e0b623b11ee klines-24.02.1.tar.xz
"