aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmail/APKBUILD')
-rw-r--r--community/kmail/APKBUILD39
1 files changed, 25 insertions, 14 deletions
diff --git a/community/kmail/APKBUILD b/community/kmail/APKBUILD
index aba85906a43..cbc2518d103 100644
--- a/community/kmail/APKBUILD
+++ b/community/kmail/APKBUILD
@@ -1,13 +1,23 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmail
-pkgver=21.04.1
+pkgver=24.02.1
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by qt5-qtwebengine
-url="https://kontact.kde.org/components/kmail.html"
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
+url="https://kontact.kde.org/components/kmail/"
pkgdesc="Email client, supporting POP3 and IMAP mailboxes"
license="GPL-2.0-or-later"
-depends="kdepim-runtime kmail-account-wizard"
+# TODO: Replace gnupg with specific gnupg subpackages that kmail really needs.
+depends="
+ gnupg
+ kdepim-runtime
+ kmail-account-wizard
+ "
makedepends="
akonadi-contacts-dev
akonadi-dev
@@ -42,6 +52,7 @@ makedepends="
kparts-dev
kpimtextedit-dev
kservice-dev
+ kstatusnotifieritem-dev
ktextwidgets-dev
ktnef-dev
kuserfeedback-dev
@@ -55,25 +66,25 @@ makedepends="
mailcommon-dev
messagelib-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
sonnet-dev
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmail-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kmail.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmail-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
-
# akonadi-sqlite-tagselectdialogtest, akonadi-sqlite-kmcommandstest,
# akonadi-sqlite-unifiedmailboxmanagertest and akonadi-mysql-unifiedmailboxmanagertestrequire
# running dbus server
@@ -87,7 +98,7 @@ check() {
skipped_tests="$skipped_tests|$test"
done
skipped_tests="$skipped_tests)"
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "$skipped_tests"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
@@ -95,5 +106,5 @@ package() {
}
sha512sums="
-77fd057f58a0a98b5e1ec96806ca210eb18701621f9322893bb232adae5ca382124fe77fe453a7e955b8a59e9c778f453e4f0218a4ad8894d8f01ce30492dadb kmail-21.04.1.tar.xz
+1273cec335b17b6013a4c121ca7e87c6e23be9370cba57d611dc40f19d8a141d5e31f86161f27cff981a1cd656d97d68b10027427dd96d6124af72d920572447 kmail-24.02.1.tar.xz
"