aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmailtransport/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmailtransport/APKBUILD')
-rw-r--r--community/kmailtransport/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/kmailtransport/APKBUILD b/community/kmailtransport/APKBUILD
index 82b0a31819d..e8dd3bf8fbb 100644
--- a/community/kmailtransport/APKBUILD
+++ b/community/kmailtransport/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmailtransport
-pkgver=21.04.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="Manage mail transport"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and mips64 blocked by libkgapi
-arch="all !ppc64le !s390x !armhf !mips !mips64"
+# ppc64le, s390x and armv7 blocked by libkgapi
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="
@@ -20,32 +23,37 @@ depends_dev="
ksmtp-dev
kwallet-dev
libkgapi-dev
- qt5-qtkeychain-dev
+ qtkeychain-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
+ "
+checkdepends="
+ dbus
+ xvfb-run
"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmailtransport-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # Requires OpenGL and running dbus
+_repo_url="https://invent.kde.org/pim/kmailtransport.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmailtransport-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ # smtpjobtest is broken
+ dbus-run-session -- xvfb-run ctest --test-dir build --output-on-failure -E "smtpjobtest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-e357f36ea9b5b955fed10e2eae8a69ef13a1a600bba72fb59a19550d49b7c91aac13d94ac1782622bca30fd33c7b165af9233c38f3838c34dcec96ced347db68 kmailtransport-21.04.1.tar.xz
+705a8e5c2dca4e009b027445bef9b822b979d229e43eabb485d8fcb2ee71b6a1681c4a0355170a617cf82409286acfd8b27ba005728a20db5cd95ca9d75a13dc kmailtransport-24.02.2.tar.xz
"