aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmbox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmbox/APKBUILD')
-rw-r--r--community/kmbox/APKBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/community/kmbox/APKBUILD b/community/kmbox/APKBUILD
index 0297a5246fe..4b37412d453 100644
--- a/community/kmbox/APKBUILD
+++ b/community/kmbox/APKBUILD
@@ -1,35 +1,42 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmbox
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="Library for accessing mail storages in MBox format"
# armhf blocked by extra-cmake-modules
-# mips, mips64 and s390x blocked by kmime
-arch="all !armhf !mips !mips64 !s390x"
+# s390x blocked by kmime
+arch="all !armhf !s390x"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="kmime-dev"
-makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmbox-$pkgver.tar.xz"
+makedepends="$depends_dev
+ extra-cmake-modules
+ samurai
+ "
subpackages="$pkgname-dev"
+_repo_url="https://invent.kde.org/pim/kmbox.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmbox-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-6ee4d7f5128ed72f2d72e867633325070009bb459e533df98f26d9eee4899b43081b709b77c6de7f646dc239a94262ef3422a37cb7df8e1ef2a590b3d352f636 kmbox-21.08.1.tar.xz
+a31cb8d740bab2ff240f0a8312cc9e9433b946694cb7e315eb7609d9f0fcdeefe8e160e9a85d88a4e1060ed8644cde14f0328305fca65e505ab766544c778a16 kmbox-24.02.2.tar.xz
"