aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmousetool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmousetool/APKBUILD')
-rw-r--r--community/kmousetool/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/kmousetool/APKBUILD b/community/kmousetool/APKBUILD
index 888e54bacbb..f587a388611 100644
--- a/community/kmousetool/APKBUILD
+++ b/community/kmousetool/APKBUILD
@@ -1,45 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmousetool
-pkgver=21.04.2
+pkgver=24.02.1
pkgrel=0
-arch="all !armhf !s390x !mips64" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kmousetool"
pkgdesc="A program that clicks the mouse for you"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
kdbusaddons-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
knotifications-dev
+ kstatusnotifieritem-dev
kxmlgui-dev
- phonon-dev
libxt-dev
libxtst-dev
+ phonon-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/accessibility/kmousetool.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-8cec6b656b5cafd53e240fbf946df5cb1666549ed571492b050c055a68f7bb1b9f08f652bb545c63f653ab8317531a15271110f7069cbbe4426d907e1fd3aa4c kmousetool-21.04.2.tar.xz
+136d0922ccc813832d672e9da648af9cf6ec483314a50fdb9ca42f211557ad91c59e22232387f6ceb13b5f54afe7d660c081189db5b92589cefb1b82585a2a6a kmousetool-24.02.1.tar.xz
"