aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmousetool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmousetool/APKBUILD')
-rw-r--r--community/kmousetool/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/kmousetool/APKBUILD b/community/kmousetool/APKBUILD
index d2328e4d51d..f587a388611 100644
--- a/community/kmousetool/APKBUILD
+++ b/community/kmousetool/APKBUILD
@@ -1,30 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmousetool
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kmousetool"
pkgdesc="A program that clicks the mouse for you"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
kdbusaddons-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
knotifications-dev
+ kstatusnotifieritem-dev
kxmlgui-dev
- phonon-dev
libxt-dev
libxtst-dev
+ phonon-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/accessibility/kmousetool.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -35,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +47,5 @@ package() {
}
sha512sums="
-e2fb79977474c5fce8ba4e601e57f2a42fd107e038ce312913098b8e8ccae829d50afabfdc4ab40edb1f4c089d1e30dbdd5c6d8d4e11b1bad8975ca6b7ddbffc kmousetool-22.04.2.tar.xz
+136d0922ccc813832d672e9da648af9cf6ec483314a50fdb9ca42f211557ad91c59e22232387f6ceb13b5f54afe7d660c081189db5b92589cefb1b82585a2a6a kmousetool-24.02.1.tar.xz
"