aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmouth/APKBUILD')
-rw-r--r--community/kmouth/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/kmouth/APKBUILD b/community/kmouth/APKBUILD
index 8afc44123c8..d6babf7076f 100644
--- a/community/kmouth/APKBUILD
+++ b/community/kmouth/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmouth
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kmouth"
pkgdesc="Speech Synthesizer Frontend"
license="GPL-2.0-or-later"
@@ -21,23 +23,25 @@ makedepends="
kio-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/accessibility/kmouth.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKF_IGNORE_PLATFORM_CHECK=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +49,5 @@ package() {
}
sha512sums="
-9dcbdb8ad7e58f0320554d859ad43cab2192437efe34014e9ee4f370356ab52572b4929eab7ddb2f1a661c635965329117649636657bf9e2ad1ce960bfa72917 kmouth-21.08.3.tar.xz
+efb32603c7907547a54d979c641742afc85ec2127d42be6fcc94e982c8d2589444eb6c45b99d7e56789e1a4f25d0c041197699df27f85c69a3bdeb9b82c7a7c7 kmouth-24.02.2.tar.xz
"