aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmouth/APKBUILD')
-rw-r--r--community/kmouth/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/kmouth/APKBUILD b/community/kmouth/APKBUILD
index 49b9d3db4ef..d6babf7076f 100644
--- a/community/kmouth/APKBUILD
+++ b/community/kmouth/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmouth
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kmouth"
pkgdesc="Speech Synthesizer Frontend"
license="GPL-2.0-or-later"
@@ -21,12 +23,13 @@ makedepends="
kio-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/accessibility/kmouth.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -38,8 +41,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-5327881b772ff133fd441e1534881d84ac14a85fea4be66c757716f8e4c74862968a217c0b2d49c60ca4b76e427c82901db0c63da9c8cb8920d907611112247c kmouth-22.04.0.tar.xz
+efb32603c7907547a54d979c641742afc85ec2127d42be6fcc94e982c8d2589444eb6c45b99d7e56789e1a4f25d0c041197699df27f85c69a3bdeb9b82c7a7c7 kmouth-24.02.2.tar.xz
"