aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmouth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmouth/APKBUILD')
-rw-r--r--community/kmouth/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/kmouth/APKBUILD b/community/kmouth/APKBUILD
index c02cc878f53..7d36fb5af22 100644
--- a/community/kmouth/APKBUILD
+++ b/community/kmouth/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmouth
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kmouth"
pkgdesc="Speech Synthesizer Frontend"
license="GPL-2.0-or-later"
@@ -21,23 +23,25 @@ makedepends="
kio-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/accessibility/kmouth.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmouth-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKF_IGNORE_PLATFORM_CHECK=ON
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +49,5 @@ package() {
}
sha512sums="
-f4d807ea015ed03240acd2a031ecfaec613c74f6f0939bac74c8b48ccc82ff5f6a7ce0be6789bd8dc30cec8a6958b1b7cc1f7a6aece4910d394f6eb8b36313c3 kmouth-21.04.3.tar.xz
+987b1b661802e415b75d1355507aa40b9581e6bbcb10e4897648a08ebb6c741da51ce0a983e408514b20a3001d5933f0626f3f31b29b07884200fcd9bcc8f478 kmouth-24.02.1.tar.xz
"