aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmplot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmplot/APKBUILD')
-rw-r--r--community/kmplot/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/kmplot/APKBUILD b/community/kmplot/APKBUILD
index 2da5f0feef6..953cab20b5f 100644
--- a/community/kmplot/APKBUILD
+++ b/community/kmplot/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmplot
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/kmplot"
pkgdesc="Mathematical Function Plotter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,24 +20,25 @@ makedepends="
ki18n-dev
kparts-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kmplot.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +46,5 @@ package() {
}
sha512sums="
-500a25163e41a1fedc121153403441abb5a6ea5db594099317739cdbcb9057864e03c9e3190b171457c1d44afea94fe2e34b7bda89019be00126ceb9c4f4ceb8 kmplot-21.12.1.tar.xz
+9b91da18f32c9c41bc77bd6ff60ffd87b7f4cb9a279198f3c0348931a73ff0bb06a6e25684222d04fc0210e3a47483a5680c0765770a521cee0a0fc59ff80d97 kmplot-24.02.2.tar.xz
"