aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmplot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmplot/APKBUILD')
-rw-r--r--community/kmplot/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/kmplot/APKBUILD b/community/kmplot/APKBUILD
index ee2a7a8f44f..9663aa99332 100644
--- a/community/kmplot/APKBUILD
+++ b/community/kmplot/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmplot
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/kmplot"
pkgdesc="Mathematical Function Plotter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,24 +20,25 @@ makedepends="
ki18n-dev
kparts-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kmplot.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +46,5 @@ package() {
}
sha512sums="
-bb99a3c96228357b37f6943718693579616c61f3cdb47745dd5e0f146caca579838ee3b610adaa159a16b1afab8082c7b2dc087c8b4025501ad7c7352daaa82e kmplot-21.08.2.tar.xz
+afcb6dc19a7640a4bbf50dfb0c0a5bd943cda885f36a6a1e089d843dcdd672ce3d02acc5b4c6d36a0789909900e99a49bc5d4ad75a5be71599e896ec78d509ae kmplot-24.02.1.tar.xz
"