aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmplot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmplot/APKBUILD')
-rw-r--r--community/kmplot/APKBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/community/kmplot/APKBUILD b/community/kmplot/APKBUILD
index f400b396886..953cab20b5f 100644
--- a/community/kmplot/APKBUILD
+++ b/community/kmplot/APKBUILD
@@ -1,32 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmplot
-pkgver=20.08.2
+pkgver=24.02.2
pkgrel=0
+# armhf blocked by extra-cmake-modules
arch="all !armhf"
-url="http://edu.kde.org/kmplot"
+url="https://edu.kde.org/kmplot"
pkgdesc="Mathematical Function Plotter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kcrash-dev kguiaddons-dev ki18n-dev kparts-dev kwidgetsaddons-dev kdoctools-dev kdbusaddons-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kguiaddons-dev
+ ki18n-dev
+ kparts-dev
+ kwidgetsaddons-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kmplot.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="a5ab803c6f71018d8681d2b280cf7d054aaf3ec501c563780b72d7845d79cd9b4f7ff87558e2236dabc81b8ea2791689c6ae4226346893707a98fddd85fe0245 kmplot-20.08.2.tar.xz"
+sha512sums="
+9b91da18f32c9c41bc77bd6ff60ffd87b7f4cb9a279198f3c0348931a73ff0bb06a6e25684222d04fc0210e3a47483a5680c0765770a521cee0a0fc59ff80d97 kmplot-24.02.2.tar.xz
+"