aboutsummaryrefslogtreecommitdiffstats
path: root/community/kmplot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kmplot/APKBUILD')
-rw-r--r--community/kmplot/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/kmplot/APKBUILD b/community/kmplot/APKBUILD
index 3c33393789a..953cab20b5f 100644
--- a/community/kmplot/APKBUILD
+++ b/community/kmplot/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kmplot
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://edu.kde.org/kmplot"
pkgdesc="Mathematical Function Plotter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,16 +20,17 @@ makedepends="
ki18n-dev
kparts-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/kmplot.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmplot-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -35,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +46,5 @@ package() {
}
sha512sums="
-ac288f7489667d6bbc84eb07c05b6b70002a246abc44bf11c75eb780a2f9f269daee04fdea199c833e9d03ca84e591e7770a6ff1878d92eb843a9fbd5930e27e kmplot-22.04.1.tar.xz
+9b91da18f32c9c41bc77bd6ff60ffd87b7f4cb9a279198f3c0348931a73ff0bb06a6e25684222d04fc0210e3a47483a5680c0765770a521cee0a0fc59ff80d97 kmplot-24.02.2.tar.xz
"