aboutsummaryrefslogtreecommitdiffstats
path: root/community/knetwalk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knetwalk/APKBUILD')
-rw-r--r--community/knetwalk/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/knetwalk/APKBUILD b/community/knetwalk/APKBUILD
index a3501a74e5a..9e0f2133eda 100644
--- a/community/knetwalk/APKBUILD
+++ b/community/knetwalk/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=knetwalk
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
pkgdesc="Connect all the terminals to the server, in as few turns as possible"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/knetwalk/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -23,23 +24,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/knetwalk-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/knetwalk.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/knetwalk-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-545d0055a003154de740187e9da8f9c209bd1835b204a7bee4b5ec7d7eeb20dc05c9d842b88deb22d26b30c11ed3047c32641dcf052dea2a5ffabc7fca44ea5e knetwalk-21.08.2.tar.xz
+f654e8f547525ae314eb7d862a0e4bf367a6a3dcc932677f8372167e3d47967a81e73cbbf9f860e605dad0f7c442e23fdfe21f6d9724ee62eab80f58a957c7f7 knetwalk-24.02.1.tar.xz
"