aboutsummaryrefslogtreecommitdiffstats
path: root/community/knights/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knights/APKBUILD')
-rw-r--r--community/knights/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/knights/APKBUILD b/community/knights/APKBUILD
index 70593bc3550..cca003ba3d0 100644
--- a/community/knights/APKBUILD
+++ b/community/knights/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=knights
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="Chess board by KDE with XBoard protocol support"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/games/knights/"
license="GPL-2.0-or-later"
makedepends="
@@ -21,17 +23,19 @@ makedepends="
kwallet-dev
kxmlgui-dev
libkdegames-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/knights-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/knights.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/knights-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-1f9136e85730cae9085b152b720475dd64dd53cec98f9d20eb67f1b68aea851b86c6781f87127bbc0ff3f385db907bd1566534bc05f3013317f33ea0b35b438b knights-21.04.3.tar.xz
+e99e816447646101f966b73babefe775aff1b57505d3c14e0d79daafb73ec6b7aad92c51a0c04bb94a5096fb87a6236a8a88e3e542ca99fe3a1ff325f2900acb knights-24.02.2.tar.xz
"