aboutsummaryrefslogtreecommitdiffstats
path: root/community/knights/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knights/APKBUILD')
-rw-r--r--community/knights/APKBUILD41
1 files changed, 32 insertions, 9 deletions
diff --git a/community/knights/APKBUILD b/community/knights/APKBUILD
index c8dc15a3d16..cca003ba3d0 100644
--- a/community/knights/APKBUILD
+++ b/community/knights/APKBUILD
@@ -1,27 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=knights
-pkgver=20.08.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="Chess board by KDE with XBoard protocol support"
-arch="all !armhf !s390x" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://www.kde.org/applications/games/knights/"
license="GPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kdbusaddons-dev kconfigwidgets-dev kcrash-dev ktextwidgets-dev kxmlgui-dev kio-dev kplotting-dev kdoctools-dev kwallet-dev plasma-framework-dev libkdegames-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/knights-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ kconfigwidgets-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kio-dev
+ kplotting-dev
+ ktextwidgets-dev
+ kwallet-dev
+ kxmlgui-dev
+ libkdegames-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/knights.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/knights-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="54fa324591c2d640b9626ce166e72bc0015162bff989231045c50d531a77e6659520ffbef7f671722289c7e2002c5362683cbb0395755aab7c49e6fea4e8b68f knights-20.08.2.tar.xz"
+sha512sums="
+e99e816447646101f966b73babefe775aff1b57505d3c14e0d79daafb73ec6b7aad92c51a0c04bb94a5096fb87a6236a8a88e3e542ca99fe3a1ff325f2900acb knights-24.02.2.tar.xz
+"