aboutsummaryrefslogtreecommitdiffstats
path: root/community/knotes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knotes/APKBUILD')
-rw-r--r--community/knotes/APKBUILD68
1 files changed, 54 insertions, 14 deletions
diff --git a/community/knotes/APKBUILD b/community/knotes/APKBUILD
index 88f8c6082fc..18926e3c5f8 100644
--- a/community/knotes/APKBUILD
+++ b/community/knotes/APKBUILD
@@ -1,40 +1,80 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=knotes
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips, ppc64le and s390x blocked by kdepim-runtime
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !mips !mips64 !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by kdepim-runtime
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://kontact.kde.org/"
pkgdesc="Popup notes"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
depends="kdepim-runtime"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev grantlee-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdnssd-dev kdoctools-dev kglobalaccel-dev kiconthemes-dev kitemmodels-dev kitemviews-dev kcmutils-dev knewstuff-dev knotifications-dev knotifyconfig-dev kparts-dev ktextwidgets-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev knotifications-dev akonadi-dev akonadi-notes-dev kcalutils-dev kontactinterface-dev libkdepim-dev kmime-dev pimcommon-dev kpimtextedit-dev grantleetheme-dev akonadi-search-dev libxslt-dev"
+makedepends="
+ akonadi-dev
+ akonadi-notes-dev
+ akonadi-search-dev
+ extra-cmake-modules
+ grantlee-dev
+ grantleetheme-dev
+ kcalutils-dev
+ kcmutils-dev
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdnssd-dev
+ kdoctools-dev
+ kglobalaccel-dev
+ kiconthemes-dev
+ kitemmodels-dev
+ kitemviews-dev
+ kmime-dev
+ knewstuff-dev
+ knotifications-dev
+ knotifications-dev
+ knotifyconfig-dev
+ kontactinterface-dev
+ kparts-dev
+ kpimtextedit-dev
+ kstatusnotifieritem-dev
+ ktextwidgets-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ libkdepim-dev
+ libxslt-dev
+ pimcommon-dev
+ qt6-qtbase-dev
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/knotes-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/knotes.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/knotes-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
-
# knotesgrantleeprinttest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "knotesgrantleeprinttest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "knotesgrantleeprinttest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-e223478d04d761ed6138f6dfbc1403ef4beb4a5d9d0e1431e6c29e016dd77ea78f1e468ea57d12f722f9ed33c095a18f0c99cccb5f2048cf6ef421ede569a86a knotes-21.08.2.tar.xz
+07d901ed258d204afd9ec2fa2310b001a9aa958b272b3a2c0028da8d606ba4515b7f3e3e35f26c8f13a54ef484c17ee54282b826d9cced31d9059097b92310a5 knotes-24.02.1.tar.xz
"