aboutsummaryrefslogtreecommitdiffstats
path: root/community/knotifications/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knotifications/APKBUILD')
-rw-r--r--community/knotifications/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/knotifications/APKBUILD b/community/knotifications/APKBUILD
index 116fce1ee5a..5c7b7f2807a 100644
--- a/community/knotifications/APKBUILD
+++ b/community/knotifications/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=knotifications
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction for system notifications"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -13,22 +16,22 @@ depends_dev="
kwindowsystem-dev
libcanberra-dev
phonon-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
- qt5-qtx11extras-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/frameworks/knotifications.git"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running dbus-daemon
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -36,13 +39,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-7b880c9e093725590d5ee7e8697196df575a14ebbf6d2a3b915ffbc5ac53b61969a302519e22e494b60e35a405a07640f814f8583bd845ff54c2c6c5f0474bde knotifications-5.84.0.tar.xz
+158706e38320b620153f048cf1075063fb46692e165663222631ca05fbb99953f679bb4a888d06d61ce2671134605b88a767c875eee9c85a042b46a7820b3df1 knotifications-6.1.0.tar.xz
"