aboutsummaryrefslogtreecommitdiffstats
path: root/community/knotifications/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knotifications/APKBUILD')
-rw-r--r--community/knotifications/APKBUILD52
1 files changed, 31 insertions, 21 deletions
diff --git a/community/knotifications/APKBUILD b/community/knotifications/APKBUILD
index 0481e780f49..5c7b7f2807a 100644
--- a/community/knotifications/APKBUILD
+++ b/community/knotifications/APKBUILD
@@ -1,41 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=knotifications
-pkgver=5.66.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction for system notifications"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
-license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="qt5-qtbase-dev qt5-qtspeech-dev qt5-qtx11extras-dev kwindowsystem-dev kconfig-dev kcodecs-dev kcoreaddons-dev phonon-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
+license="BSD-3-Clause AND LGPL-2.0-or-later AND LGPL-2.0-only AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends_dev="
+ kconfig-dev
+ kcoreaddons-dev
+ kwindowsystem-dev
+ libcanberra-dev
+ phonon-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/frameworks/knotifications.git"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running dbus-daemon
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="f5a2f809204e87714577e24dc6a9e5d8556bab4a19a491b6dd45ef62f379861e6a2bcba9e023ab60a004f574cf8ec41a3c4764e301cfd085d4eb90c1d7561ec1 knotifications-5.66.0.tar.xz"
+
+sha512sums="
+158706e38320b620153f048cf1075063fb46692e165663222631ca05fbb99953f679bb4a888d06d61ce2671134605b88a767c875eee9c85a042b46a7820b3df1 knotifications-6.1.0.tar.xz
+"