aboutsummaryrefslogtreecommitdiffstats
path: root/community/knotifications/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knotifications/APKBUILD')
-rw-r--r--community/knotifications/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/knotifications/APKBUILD b/community/knotifications/APKBUILD
index 009343a6a2f..5c7b7f2807a 100644
--- a/community/knotifications/APKBUILD
+++ b/community/knotifications/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=knotifications
-pkgver=5.96.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction for system notifications"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -13,19 +16,18 @@ depends_dev="
kwindowsystem-dev
libcanberra-dev
phonon-dev
- qt5-qtbase-dev
- qt5-qtspeech-dev
- qt5-qtx11extras-dev
+ qt6-qtbase-dev
+ qt6-qtspeech-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
+_repo_url="https://invent.kde.org/frameworks/knotifications.git"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Fails due to requiring running dbus-daemon
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifications-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -37,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +47,5 @@ package() {
}
sha512sums="
-a38af9f7fb2d472589846e0b62ee56865f229662167bfc09b7e85ae18619fe67a71f06c4ddfc8da81093736810ba5db82ac91b5fd40bbb88357ff647d91746e9 knotifications-5.96.0.tar.xz
+158706e38320b620153f048cf1075063fb46692e165663222631ca05fbb99953f679bb4a888d06d61ce2671134605b88a767c875eee9c85a042b46a7820b3df1 knotifications-6.1.0.tar.xz
"