aboutsummaryrefslogtreecommitdiffstats
path: root/community/kolourpaint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kolourpaint/APKBUILD')
-rw-r--r--community/kolourpaint/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/kolourpaint/APKBUILD b/community/kolourpaint/APKBUILD
index d3f256fea13..a4882a551b8 100644
--- a/community/kolourpaint/APKBUILD
+++ b/community/kolourpaint/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kolourpaint
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="http://www.kolourpaint.org/"
pkgdesc="An easy-to-use paint program"
license="BSD-2-Clause AND LGPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- kdelibs4support-dev
kdoctools-dev
kguiaddons-dev
ki18n-dev
@@ -22,22 +23,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libksane-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kolourpaint-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/kolourpaint.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kolourpaint-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +48,5 @@ package() {
}
sha512sums="
-ed0b78ea44bfef2047a35e0fe6e55b0b1a30999a3c2de476dde4869f538f21973cf7288df2f8198ff49d8f89fb107edcee2470672acad74580a411a8f4700ce9 kolourpaint-21.12.1.tar.xz
+4277ba48582a1ee3c62e95e00f4d8c3e048348eab5e2d75f0579e5e4b179da85793d6cf744b423c3991e9c6501fa4f9d78bfb8fa7389b9e9f334eb61a78000e0 kolourpaint-24.02.2.tar.xz
"