aboutsummaryrefslogtreecommitdiffstats
path: root/community/kolourpaint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kolourpaint/APKBUILD')
-rw-r--r--community/kolourpaint/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/kolourpaint/APKBUILD b/community/kolourpaint/APKBUILD
index 509a7500601..a4882a551b8 100644
--- a/community/kolourpaint/APKBUILD
+++ b/community/kolourpaint/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kolourpaint
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="http://www.kolourpaint.org/"
pkgdesc="An easy-to-use paint program"
license="BSD-2-Clause AND LGPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- kdelibs4support-dev
kdoctools-dev
kguiaddons-dev
ki18n-dev
@@ -22,14 +23,16 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libksane-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kolourpaint-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/kolourpaint.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kolourpaint-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -37,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +48,5 @@ package() {
}
sha512sums="
-6c8e16d32b70fcdc7d826a1aba5dc43b61d0a826cfd48ab9360fe834a36644a59fba467ba03d9bb8e3532eaae3f7f07de251e82e83a6bd7960f9f66265603d01 kolourpaint-22.04.0.tar.xz
+4277ba48582a1ee3c62e95e00f4d8c3e048348eab5e2d75f0579e5e4b179da85793d6cf744b423c3991e9c6501fa4f9d78bfb8fa7389b9e9f334eb61a78000e0 kolourpaint-24.02.2.tar.xz
"