aboutsummaryrefslogtreecommitdiffstats
path: root/community/kompare/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kompare/APKBUILD')
-rw-r--r--community/kompare/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/kompare/APKBUILD b/community/kompare/APKBUILD
index 314a62498d9..fd9f2171ec0 100644
--- a/community/kompare/APKBUILD
+++ b/community/kompare/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kompare
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kiconthemes
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/development/org.kde.kompare"
pkgdesc="Graphical File Differences Tool"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,15 +23,16 @@ makedepends="
ktexteditor-dev
kwidgetsaddons-dev
libkomparediff2-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kompare-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/kompare.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kompare-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -37,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +48,5 @@ package() {
}
sha512sums="
-d1c08b76d8ec9598c920e9976b69206e65f9b56b36dfa6ac3a0236abe0f9fddd4467b1d83b489e51b62de749defcc3dd3df28b96994fbfd99c4e0998a38fb5c0 kompare-22.04.0.tar.xz
+992e8f4f89462a65967e872324c157d9a3a611d2336e8ce58e5680c18b1c142abd3d1ebb1d9e82f1ed91b5904b5084de7bcb67c5f5c753e6205c1bf60f15df10 kompare-24.02.2.tar.xz
"