aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/konsole/APKBUILD')
-rw-r--r--community/konsole/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index 1c4ce02c047..032ff2c5097 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=konsole
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
@@ -24,7 +26,6 @@ makedepends="
kguiaddons-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -36,14 +37,14 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
samurai
"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz
- 0001-fix-musl-compatibility.patch
- "
+checkdepends="mesa-dri-gallium xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/konsole.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -55,11 +56,22 @@ build() {
}
check() {
- cd build
-
# DBusTest requires running DBus
- # HistoryTest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(DBus|History)Test"
+ local skipped_tests="("
+ local tests="
+ DBus
+ History
+ "
+ case "$CARCH" in
+ armv7)
+ tests="$tests Part"
+ ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)Test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
@@ -67,6 +79,5 @@ package() {
}
sha512sums="
-cd8ecc3e494cc2c087e03b4537b822986d36a04d75edf9c8d053a79578e148498582238f96018262cc74cdf86fe7abf7a0a4408e220ec0a9a49bb94d8aa10a76 konsole-22.04.2.tar.xz
-6f9f5eb53629df0392abe26391a137c3bb9ced79dbf3e649d99046318d6c897e5803bc31eeb25fd042ce24c4f124a5b0fede8c90eb2b4a5682d46826e4e9c44c 0001-fix-musl-compatibility.patch
+de3154d198fb3e7bfd91e06faeafafcf75478c85af46443c04bd98e5a267bd0eea28e162cd7827858cb9c17880bd7f947983bf81e9ba8aa6647820691cf42042 konsole-24.02.2.tar.xz
"