aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/konsole/APKBUILD')
-rw-r--r--community/konsole/APKBUILD50
1 files changed, 33 insertions, 17 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index bfe45b86386..032ff2c5097 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=konsole
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
@@ -24,7 +26,6 @@ makedepends="
kguiaddons-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -36,26 +37,41 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
+ samurai
"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
+checkdepends="mesa-dri-gallium xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/konsole.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_PLUGIN_SSHMANAGER=ON
cmake --build build
}
check() {
- cd build
-
# DBusTest requires running DBus
- # HistoryTest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(DBus|History)Test"
+ local skipped_tests="("
+ local tests="
+ DBus
+ History
+ "
+ case "$CARCH" in
+ armv7)
+ tests="$tests Part"
+ ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)Test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
@@ -63,5 +79,5 @@ package() {
}
sha512sums="
-490271a51304d5a64111f6ae74422a6b3143a5349359e55af0845c04a6e6d405fadd1f300dc4d866b7730c0cb852bebfddbb33b0ca9e68d22f264e379d1868e8 konsole-21.04.3.tar.xz
+de3154d198fb3e7bfd91e06faeafafcf75478c85af46443c04bd98e5a267bd0eea28e162cd7827858cb9c17880bd7f947983bf81e9ba8aa6647820691cf42042 konsole-24.02.2.tar.xz
"