aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/konsole/APKBUILD')
-rw-r--r--community/konsole/APKBUILD47
1 files changed, 31 insertions, 16 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index eb5844ab8d8..3e7d5ae0a06 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=konsole
-pkgver=21.08.1
+pkgver=24.02.1
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
@@ -24,7 +26,6 @@ makedepends="
kguiaddons-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -36,15 +37,18 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
+ samurai
"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
+checkdepends="mesa-dri-gallium xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/konsole.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_PLUGIN_SSHMANAGER=ON
@@ -52,11 +56,22 @@ build() {
}
check() {
- cd build
-
# DBusTest requires running DBus
- # HistoryTest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(DBus|History)Test"
+ local skipped_tests="("
+ local tests="
+ DBus
+ History
+ "
+ case "$CARCH" in
+ armv7)
+ tests="$tests Part"
+ ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)Test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
@@ -64,5 +79,5 @@ package() {
}
sha512sums="
-ebac48f71bde793e39fc2f3c0dc39f8fc24e6f9ba8447988ee793ef33154bcbc7f97dfe863b708acc85c472e424c4190625fc8139417f4a98520c4c9a903903d konsole-21.08.1.tar.xz
+23e11f15643b57de10c34ff738f6386b7644dba21ae729b2df6334035a7fd2949c29bf504348e73a68310e00571bab8186ddceae79ee770310c98e0e25a6c3eb konsole-24.02.1.tar.xz
"