aboutsummaryrefslogtreecommitdiffstats
path: root/community/konsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/konsole/APKBUILD')
-rw-r--r--community/konsole/APKBUILD52
1 files changed, 35 insertions, 17 deletions
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index e0ccdea55bf..3e7d5ae0a06 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=konsole
-pkgver=21.04.0
+pkgver=24.02.1
pkgrel=0
-# armhf blocked by qt5-qtdeclarative
-# s390x and mips64 blocked by various KDE frameworks
-arch="all !armhf !s390x !mips64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
@@ -24,7 +26,6 @@ makedepends="
kguiaddons-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
@@ -36,30 +37,47 @@ makedepends="
kwidgetsaddons-dev
kwindowsystem-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ qt6-qtmultimedia-dev
+ samurai
"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
+checkdepends="mesa-dri-gallium xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/konsole.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/konsole-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_PLUGIN_SSHMANAGER=ON
cmake --build build
}
check() {
- cd build
-
# DBusTest requires running DBus
- # HistoryTest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(DBus|History)Test"
+ local skipped_tests="("
+ local tests="
+ DBus
+ History
+ "
+ case "$CARCH" in
+ armv7)
+ tests="$tests Part"
+ ;;
+ esac
+ for test in $tests; do
+ skipped_tests="$skipped_tests|$test"
+ done
+ skipped_tests="$skipped_tests)Test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "$skipped_tests"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="35cb9822c442bc3dcec0539451f2bd1672c27ea522a2dc412e7cffbd805497c58711a9035e2af3ba5cb804dc42da5563bb3a6017774d22000870bc9e7450402e konsole-21.04.0.tar.xz"
+sha512sums="
+23e11f15643b57de10c34ff738f6386b7644dba21ae729b2df6334035a7fd2949c29bf504348e73a68310e00571bab8186ddceae79ee770310c98e0e25a6c3eb konsole-24.02.1.tar.xz
+"