aboutsummaryrefslogtreecommitdiffstats
path: root/community/kontact/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kontact/APKBUILD')
-rw-r--r--community/kontact/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index 0cd3ff81325..36b4325a113 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kontact
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !riscv64"
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
@@ -24,12 +27,13 @@ makedepends="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
samurai
"
+subpackages=" $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kontact.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kontact-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
cmake -B build -G Ninja \
@@ -40,8 +44,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -49,5 +52,5 @@ package() {
}
sha512sums="
-a2d25a1a6f6bfd0cd5282149af27d1240079e8377f2b002d5cf90e13c55549ab897415255058e1a9b83a14448a587aa0d7cc947de7721ad13375434c1f2a223a kontact-22.04.3.tar.xz
+df5bd9bd159a25fc6ad27fc5397f8969d26180b2ff3224ff8d96f04c1512202060bfc89ad56e9f8c9c0ad03dfb24206718944f2cb433782cae912fd62dbe4c3d kontact-24.02.2.tar.xz
"