aboutsummaryrefslogtreecommitdiffstats
path: root/community/kontact/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kontact/APKBUILD')
-rw-r--r--community/kontact/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index 86b0be747d9..36b4325a113 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kontact
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
@@ -24,23 +27,24 @@ makedepends="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
"
+subpackages=" $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kontact.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kontact-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -48,5 +52,5 @@ package() {
}
sha512sums="
-2dc05f7bec175226ad35d74b834464f8ca3e4752c79a5b6fe0c12d6e1ed945be4e99da0c481ed121eb6893c72a4d7ceb23dd6146eb897cc560333ffbbf858262 kontact-21.12.1.tar.xz
+df5bd9bd159a25fc6ad27fc5397f8969d26180b2ff3224ff8d96f04c1512202060bfc89ad56e9f8c9c0ad03dfb24206718944f2cb433782cae912fd62dbe4c3d kontact-24.02.2.tar.xz
"