aboutsummaryrefslogtreecommitdiffstats
path: root/community/kontact/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kontact/APKBUILD')
-rw-r--r--community/kontact/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index c8406555a9b..36b4325a113 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -1,9 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kontact
-pkgver=21.04.0
+pkgver=24.02.2
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by qt5-qtwebengine
+# armhf blocked by extra-cmake-modules
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
@@ -21,27 +27,30 @@ makedepends="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
"
+subpackages=" $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kontact.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kontact-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="0ce725ce483e3678b87d0281dde3df4ebb66e33a3215a133078d2492aeed827ea0ba78074829d634cf31f99d60a30c2abfcd786eaf2572a7dafc051c55baba52 kontact-21.04.0.tar.xz"
+sha512sums="
+df5bd9bd159a25fc6ad27fc5397f8969d26180b2ff3224ff8d96f04c1512202060bfc89ad56e9f8c9c0ad03dfb24206718944f2cb433782cae912fd62dbe4c3d kontact-24.02.2.tar.xz
+"