aboutsummaryrefslogtreecommitdiffstats
path: root/community/kontact/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kontact/APKBUILD')
-rw-r--r--community/kontact/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index 90c2e842c44..11d02dee94e 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -1,12 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kontact
-pkgver=21.08.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
+# armv7, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+arch="all !armv7 !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
@@ -24,23 +27,24 @@ makedepends="
kwindowsystem-dev
libkdepim-dev
pimcommon-dev
- qt5-qtbase-dev
- qt5-qtwebengine-dev
+ qt6-qtbase-dev
+ qt6-qtwebengine-dev
+ samurai
"
+subpackages=" $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kontact.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/kontact-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -48,5 +52,5 @@ package() {
}
sha512sums="
-ae534010f34fb930a55a3a9550ed85099182e94d330333636da535a308f97d50cb051be5ac988aceec913ca5e1eaa7ff7720c83444f1060e44874b42b15938a6 kontact-21.08.1.tar.xz
+3248a42f6e273bd62961a2945202f41d9152f3bd2ad2a9be9aece28aac61849187cb116b94d19c52d908143d35bd33a07b4cc547b98cf5aab115ee196571b5c7 kontact-24.02.1.tar.xz
"