aboutsummaryrefslogtreecommitdiffstats
path: root/community/kparts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kparts/APKBUILD')
-rw-r--r--community/kparts/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/kparts/APKBUILD b/community/kparts/APKBUILD
index 104ac140d56..4d9a91eb45a 100644
--- a/community/kparts/APKBUILD
+++ b/community/kparts/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kparts
-pkgver=5.95.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Document centric plugin system"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="
@@ -20,17 +22,18 @@ depends_dev="
ktextwidgets-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kparts-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kparts.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kparts-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -42,8 +45,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -51,5 +53,5 @@ package() {
}
sha512sums="
-6d388afe676cdb07d47261ad394820c948f37314b4d7745e9ae621f13a65f9d4bc2516f05538b90cfeb40d5c06ed699262c091d30dcdd669c66bce53633e12f8 kparts-5.95.0.tar.xz
+0d1a12de2069667416fbd314c5fa101a551d774e796fbdc0f8c4482ebbda58010490c22f3a179b3553b19559ab8e6f15921598196e18f146126b59e027652e4a kparts-6.0.0.tar.xz
"