aboutsummaryrefslogtreecommitdiffstats
path: root/community/kpat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kpat/APKBUILD')
-rw-r--r--community/kpat/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/kpat/APKBUILD b/community/kpat/APKBUILD
index 9a8445011b3..f97085dfb22 100644
--- a/community/kpat/APKBUILD
+++ b/community/kpat/APKBUILD
@@ -1,14 +1,17 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kpat
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="KPatience offers a selection of solitaire card games"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/kpat/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
+depends="carddecks"
makedepends="
black-hole-solver-dev
extra-cmake-modules
@@ -27,24 +30,25 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kpat-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kpat.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kpat-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "kpat-GolfSolveTest"
}
package() {
@@ -52,5 +56,5 @@ package() {
}
sha512sums="
-5f500a21b63d7ff9979333c0f1fdf36abcd6d4cd66f2e8dd73f152ae08e058a7eb201a690f013fc90485d6f1681796a31eb196fb03c600b7ae150dcf2e139694 kpat-21.12.1.tar.xz
+e3784523968ffff2fa6f4681ee4cea841cc190419759995d20e374ad533a88c00dea68312a87fd55f2721f0fa262b84f3ac16b84edded9570c3c70711ccbf2db kpat-24.02.2.tar.xz
"